Joomla 1.5.0 to 3.4.5 Object Injection via User-Agent

This exploit is Copyright (C) 2007-2017 DSquare Security, LLC.


Description: Joomla suffers from an unauthenticated remote code execution that affects all versions from 1.5.0 to 3.4.5. By storing user supplied headers in the databases session table it's possible to truncate the input by sending an UTF-8 character. The custom created payload is then executed once the session is read from the databse. You also need to have a PHP version before 5.4.45 (including 5.3.x), 5.5.29 or 5.6.13. In later versions the deserialisation of invalid session data stops on the first error and the exploit will not work. The PHP Patch was included in Ubuntu versions 5.5.9+dfsg-1ubuntu4.13 and 5.3.10-1ubuntu3.20 and in Debian in version 5.4.45-0+deb7u1.
Family: Remote Command Execution
Bugtraq ID:
CVE ID:
VULNDB ID: VULNDB-131679

Back to Exploits

Share :   Facebook   Twitter   Google+